Error running this command: svn --non-interactive --config-dir /tmp

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Error running this command: svn --non-interactive --config-dir /tmp

jhalim10
Hi guys,

I am new to websvn. I have installed rancid, svn, and websvn today. I have also created repository for testing. All looks good until I encountered the following error while browsing:
http://server_ip/websvn/

Error running this command: svn --non-interactive --config-dir /tmp list --xml 'file:///var/rancid/svn/@'

Any idea why this is happening? I have modified the /usr/share/websvn/include/config.php to include the repository directory:
$config->addRepository('EXAMPLE', 'file:///var/rancid/svn/');

When I run the command manually, it looks that I am getting a good result:

svn --non-interactive --config-dir /tmp list --xml 'file:///var/rancid/svn/@'
<?xml version="1.0"?>
<lists>
<list
   path="file:///var/rancid/svn">
<entry
   kind="dir">
<name>EXAMPLE</name>
<commit
   revision="6">
<author>rancid</author>
<date>2014-08-08T14:29:14.284275Z</date>
</commit>
</entry>
</list>
</lists>

I am sorry if this has been discussed before. I have tried to search in the topics, but return nothing. Many thanks.

Cheers,
Jim